Jump to content

philb

Members
  • Posts

    258
  • Joined

  • Last visited

Everything posted by philb

  1. Great work, Richard. I'm looking forward to seeing it.
  2. Sorry, "Rob", I must learn to type someday.
  3. Brilliant rob, you must be pleased. Looking forward to seeing it at some events, whenever.
  4. Brilliant work Rob, you're a real dynamo!
  5. It sounds like an empty limber would qualify as an unladen trailer but what about a 25 pounder? Serious question.
  6. Look in Clive's corner for "all charged up", it will tell you everything.
  7. Update: Thanks to Keith Benfield's detective work we now have the hull number and Bovington are going to provide supporting paperwork for DVLA.
  8. Thanks Robin. I found him on the British and Commonwealth Soft-skins group.
  9. Thanks chaps. I found the plate but the hull number has been obliterated by someone - on purpose. Any chance of finding the hull number from the army number? Bovington can't help.
  10. Success! We found a chap in Norway with a shed full (nearly) of Morris axles - he sold us a half-shaft.
  11. Thanks again Richard. Today we wound the clevis link on the gear lever in by two turns and now all the gears are selected with ease. Our next problem is to get the thing road registered but we don't know its chassis number. The data plate seems to have disappeared, all we have is the army number 01EA27. Does anyone know if the chassis(?) number is stamped on it somewhere please? Phil
  12. Now I've done the sensible thing and looked at a data book, I can see that the vales are not masked. Trying to be more helpful, it seems the O600 was fitted to some Hippos (as well as lots of commercial vehicles).
  13. Thanks Richard. I'll update the records in my head.
  14. Aren't the Leyland 600 inlet valves masked?
  15. Six, I think. Won't know for sure until next week.
  16. Thanks Richard, I'll have a look at the linkage. Trying to remember but I think the pedal works as normal once 3rd is engaged. Phil
  17. My pal's Ferret will readily engage 1st, 2nd, 4th and 5th gears but having selected 3rd gear and pressed the pedal the pedal stays down, as if in neutral. After a few attempts the pedal usually springs up with a bang and 3rd is engaged but that makes driving tricky. Is this a common problem and what is the likely cause please? Cheers, Phil
  18. Does anyone have, or know of, a Morris Quad offside half shaft for sale please? Alternatively a complete rear axle? Phil
  19. Clive, The Ferret does seem to have an alternator. Any idea where the ignition fuse/cutout is? Phil
  20. I don't know. I'll try to find out next week.
  21. Thanks Clive. Where are the fording caps? Our panel does not seem to have them. Phil
  22. A pal of mine has just bought a Ferret and I'm trying to help him get it running. With a pair of good batteries all the electrics work except that the oil and generator warning lights are off and the starter circuit does not work when the ignition switch is on. We have EMERs but they seem to describe earlier (I guess) versions of the generator panel which we think have a fuse for the ignition circuit. Our panel does not seem to have fuses anywhere. So, my question is: how is the ignition circuit protected and what do I have to do to energise it? Any help appreciated. Phil
×
×
  • Create New...