Jump to content
joeferret

Fuses or relay for headlights in my 1954 ferret MK1 ?

Recommended Posts

Can someone tell me please regarding a 1954 Ferret MK1 for the headlights is there a fuse or relay for them ? IF there is where is it located ? Do the headlights have all 24 volts going to them ?

 

Thank you for any responses,

 

Joe in USA

Share this post


Link to post
Share on other sites

Joe there are two thermal cutouts in the Distribution Box No.1 Mk 1. 10A and 30A, the headlights come from the 30A one. If there has been a short circuit it will take a minute or so to recover. If no recovery then water may have got in and it will be rusted up.

 

Yes they get full 24v.

 

The Distribution Box box has the jump start socket.

Edited by fv1609

Share this post


Link to post
Share on other sites
Joe there are two thermal cutouts in the Distribution Box No.1 Mk 1. 10A and 30A, the headlights come from the 30A one. If there has been a short circuit it will take a minute or so to recover. If no recovery then water may have got in and it will be rusted up.

 

Yes they get full 24v.

 

The Distribution Box box has the jump start socket.

 

So is it just the headlights that run off the 30 amp and the turn/stop/tail lights on the 10 amp ?

Thank you Clive.....

 

Joe in USA

Edited by joeferret

Share this post


Link to post
Share on other sites

Joe basically:

 

10A Instruments & ignition

Can carry:

11A for 15 mins

20A for 10-25 secs

 

 

30A Lights & horn

Can carry:

35A for 15 mins

60A for 11-50 secs

 

So there is a bit of latitude if you have an overload.

Share this post


Link to post
Share on other sites
Joe basically:

 

10A Instruments & ignition

Can carry:

11A for 15 mins

20A for 10-25 secs

 

 

30A Lights & horn

Can carry:

35A for 15 mins

60A for 11-50 secs

 

So there is a bit of latitude if you have an overload.

 

Thank you very much sir...That's what I needed...I wish you the very best with your vehicles...

Sincerely,

 

Joe in USA

Share this post


Link to post
Share on other sites
have u got your fsc up and driving joe?

Pretty much...Just put on new brake hoses and got the brakes going....GSP restored ect..Now working on getting the lights working..I have it up on blocks wheels off...I couldn't go anywhere out of it's garage as there is about a foot of snow out....I hope to have it driving around the neighborhood in may...Slowly getting it working better....VERY cold here the past 3 months.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...