Jump to content

oil leak on Dodge T215 engine


panelvan
 Share

Recommended Posts

its been difficult to get access to my Dodge as it is at my works and we are closed because of the virus situation so i can  only go by arrangement. i have packed the oil pump and i now have to refit the sump using a gasket set. does anyone have any recomondations or tips regarding this and what gasket goo to use please

Link to comment
Share on other sites

7 minutes ago, panelvan said:

forgot to say i already have the gasket set.

Ordinary goo would be fine, anything you have in the shop.  The only things to watch are in the rear sump to main bearing cap to block area.  Never re-fit the back main bearing cap without new "h" seals, for example

Link to comment
Share on other sites

  • 2 weeks later...

Hello there.

having managed to get access to my Dodge yesterday i can report that i think i may have sorted out the low oil pressure problem.

my earlier posts show what the issue was and what fixes had been suggested and what i had already tried.

Eventually i followed the suggestion of taking off the oil pump and packing the pump gears . I used

Castrol spheerol classic . I did this on a bench after carefully marking with a paint pen the spiral worm gear and its tube ,  then i (reluctantly) dropped the sump pan, gave it a thorough clean and jetwash,  but to be fair it was not that bad really anyway !  I took off and cleaned the floating oil pick up filter which was really dirty. Put new cork gaskets on. and re fitted the sump. The job  of removing and refitting the sump was something i had not been looking forward to doing ,  and it was not an easy task. Access was awkward lying on my back working under the Dodge. everything seemed to be in the way, axle, diff, tie rod , exhaust. After filling with 20/50 oil i tried to start it. It wouldnt go so got a gallon can of petrol 'just in case, and success... it started. Checking the oil pressure my heart sank it was zero!!! then i remembered i had disconnected the original oil guage and teed off  a pipe to a modern guage in case the original one was faulty. doh!!!  Checking the modern guage i was pleased to see a reading of just over 30 psi. I left it ticking over for about 10 minutes and the pressure slowly dropped to 21 psi and stayed at that climbing to around 30 psi on pressing the accelerator. I was hoping for a bit higher tick over but at last it is out of  its" sick bed " it seems and it drives again.

20200424_084405.jpg

20200424_084609.jpg

  • Like 1
Link to comment
Share on other sites

  • 1 year later...

Hello, im panelvan's. (Mikes) son.

my Dad sadly passed away earlier this year.

I now own the Dodge and recovered it from my Dads works with the head off the engine.

I fitted the new head gasket and put 15/40 mineral oil in it.

Ive been driving the Dodge a fair bit and been to a show in it which was quite far in busy traffic on a hot day and everything has been fine.

The temperature gets upto a little over 140 and stays there. The oil pressure is 40 on start up and drops to 20 when its fully warmed up, but as soon as its given any revs the oil pressure goes upto 40 again.

How do these readings sound and what would be the ideal oil pressure for this engine while at revs and at tick over?

 

  • Like 1
Link to comment
Share on other sites

As I mentioned up thread that's fine for a worn engine.  As I understand it the oil pressure gauge just shows you the pressure at the main bearings, the big ends are too far 'down' the supply line to reflect on the gauge.  Drive it cautiously and enjoy it.

If it hasn't been driven much, then modern detergent oil is liable to flush a pile of crap out of the interior the engine, and some of that can get in important places.  You have cleaned the sump which will have got rid of much of it, but now and again it would still be worth warming it up then draining the oil to let it settle in a pan, then pouring the clean oil back in.

 If any substantial amount of dirt settles out, change the filter then repeat the process after some more use.

  • Thanks 1
Link to comment
Share on other sites

5 hours ago, Keith-wc42 said:

Hello, im panelvan's. (Mikes) son.

my Dad sadly passed away earlier this year.

I now own the Dodge and recovered it from my Dads works with the head off the engine.

I fitted the new head gasket and put 15/40 mineral oil in it.

Ive been driving the Dodge a fair bit and been to a show in it which was quite far in busy traffic on a hot day and everything has been fine.

The temperature gets upto a little over 140 and stays there. The oil pressure is 40 on start up and drops to 20 when its fully warmed up, but as soon as its given any revs the oil pressure goes upto 40 again.

How do these readings sound and what would be the ideal oil pressure for this engine while at revs and at tick over?

 

Firstly sorry hear of your Fathers passing but well done you for taking the truck on,  so many get sold on by family in double quick time these days.

To address your question,  the numbers you quote sound just fine for an engine with some miles on it Gordon's advice is worth following perhaps before the winter lay up.

Otherwise enjoy the rare truck you now own drive it with the respect that a vehicle of it's age requires and it will last a life time.

Pete 

  • Thanks 1
Link to comment
Share on other sites

Thank you Gordon and Pete for your help.

Pete...thanks for your kind words. Im really enjoying the Dodge. Because it means so much to me i think that enjoyment is marred a little bit due to being extra worried about doing something wrong, but im sure my confidence will grow with time.

I will change the oil again soon. Im not sure whether to stick with 15/40 or to try 20/50 again like my Dad put in it.

The logical thing to do is to stick with the 15/40, as where im getting 40psi, my Dad was getting around 30psi. The 15/40 just seems a little thin on the dip stick to me though.

I've been told by a few people that the oil pressure is spot on, but i didn't realize that was for a worn engine. Do you know what sort of pressure it would have from the factory?

 

  • Like 1
Link to comment
Share on other sites

I'd think from the factory it would be 50 cold and 20 at hot idlI.  it would never have been that high at hot idle, and it wouldn't really have to be.

Link to comment
Share on other sites

Rather off topic, but on the subject of driving it cautiously, to me when driving it is that the only time the engine is put under any stress is when setting off.

First gear is so short and when you need to get going like at a roundabout or junction, you want it rolling and going so it's not almost come to a stop by the time you get it into 2nd.

I've read that a lot of people set off in 2nd, but what is best really long term? I would have thought that would take its toll on the clutch.

Link to comment
Share on other sites

Oh my, you are using first gear?   First should be reserved for setting off uphill, with a full load, or towing a trailer. Think of it as a three-speed box with an additional granny gear.

Starting in second should be fine, the number of changes is greatly reduced and that will help make up for any extra effort. Additionally, only ever select first or reverse when completely stationary, unless you like working on gearboxes.

  • Thanks 1
Link to comment
Share on other sites

That's music to my ears...thanks for that.

Driving it will be so much nicer without using that 1st gear.

Last time I drove this before my Dad passed away was around 20 years ago, so it's a bit new to me....done all my driving in his jeep.

My Dad probably put no more than 100 miles on it after he rebuilt the engine back in 1991, so I never got much chance to drive the Dodge.

I'm looking forward to my next convoy more now!

Link to comment
Share on other sites

As Gordon says above treat it as a three speed box with additional crawler gear in first. 

Many years ago now I did a conversion for a customer on a Carryall where he wanted a higher road speed so he provided a set of power wagon difs with higher ratio than the war time WC ones. 

It completely changed the characteristics of the truck using first was now a necessity at junctions lights and roundabouts  and as you have found 1st to 2nd is a long pull without much road speed to keep the truck moving. However it added about 10 mph to the cursing speed in top but was a night mare on hills as it ran out of puff in top very quickly and then it was foot to the floor in 3rd all the way up hovering over the stick waiting to pull second on occasions something on a stock WC that is only required when climbing a mountain..

The foot note to this is the customer was very happy with the result as he was moving to the Fenlands no hills and long flat roads.

Pete

  • Thanks 1
Link to comment
Share on other sites

Very interesting Pete. Im not letting my son read that though....he has already said why don't i put a diesel engine it it!

 

Thanks both of you for your help and helping my Dad too. Im sure i will be pestering you both again before too long.

 

Here is the engine now after a head repaint.

engine 1.jpg

engine 2.jpg

  • Like 1
Link to comment
Share on other sites

Just an observation Keith on your last photo,

you may wish to put a rubber grommet on your oil gauge line where it passes through the bulkhead. A combination of vibration and chaffing could end up with no oil pressure and a nasty mess to clear up

regards

Pete

Link to comment
Share on other sites

Sorry to hear your news. But he solved the problem . The manual says 15 psi for oil on idle, so you fine. Depending on oil if you do a long hot run the pressure can drop right down at idle. Just let the engine idle cool till the pressure come up before switching off,

Link to comment
Share on other sites

Posted (edited)

Forgot to ask, before i change the oil again, should i get the same oil as I put in it a couple of weeks ago which was G-Force 15/40 Mineral oil, or get another type?

Edited by Keith-wc42
Link to comment
Share on other sites

I got a couple of cans of Halfords Classics 20/50 today. I didn't know it was green....hmm.

Anyway, i warmed the engine, raised the front end a little and dranied it. When the oil had finished draining i poured a fair bit of my remaining 15/40 through with the sump plug still off, just to help flush out any crud that might have started to build in the sump again.

I removed the filter housing (NOT by the bracket using the head bolts) to tip out the oil, as i had nothing that would fit under the drain plug.

Filled the sump to the full line on the stick, but this time i didn't put all that much oil in the filter housing....the reason being that last time i filled the housing, i ended up having to drain out extra oil after running the engine for a minute.

Cranked the engine around with the handle, but with the plugs in i only gave it a few turns.

Started it up and the oil pressure immediately went to just below 40. I only let it tick over for about 20 seconds or so, as i knew it would need topping up.

On checking the level on the dip stick, it was on the bottom line, possibly even a shade below it! So i finished off the first can and got it close to full.

On removing the screw cap on the second can of oil, i noticed the plastic seal had a hole punched in it. I wasn't happy with this, but really wanted to finish the job so i went to lever the plastic seal off. The seal cap pretty much fell off as soon as i touched it...the plastic seal cap on the first can was quite hard to remove. So i didn't use this second can and im taking it back to Halfords tomorrow. I think its a store return and the oil could have been through someones engine for all i know.

 

So with the oil level a little lower than i would like, i didn't drive it, i just started it and let it tick over for a couple of minutes.

I suppose my last question is really looking for reassurance..... Do you think it will be ok after it running for 20 seconds or so when the oil level dropped to minimum, maybe even a fraction below due to the oil filter housing taking it?....Its just that I let it drain for a long time until the sump stopped dripping. The oil pressure was just a little under 40 for the whole 20 seconds or so it was running though.

pressure.jpg

Link to comment
Share on other sites

It will be fine, no problem, just get it up to the mark before driving it.  

I wouldn't discard the new oil you drained out either, I'd put it in clear containers and let any dirt or water settle out a couple of times then just use it for topping up.

  • Thanks 1
Link to comment
Share on other sites

I took the Dodge out yesterday and the oil pressure when fully warmed up is better than when i was using 15/40.

It drops from a shade under 40 at idle to around 28psi at idle when fully warmed up....always climbing back close to 40 with any revs

Temperature was always just slightly over 140 the whole time and i was in rush hour traffic on a hot day.

It was much nicer setting off in 2nd gear.

 

One more thing i've learned is that Dodge is good for going to Tesco in, as i have an excuse to wait in the vehicle while my wife does the shopping.

Here are a couple of photos in Tesco car park....

1.jpg

2.jpg

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...