Jump to content
Tamber

It's here! (Bedford RL)

Recommended Posts

The compressor is currently on my workbench, having had the sump washed out with petrol to break up the sludge a bit more, and new oil put in it to circulate for a while to flush out any more lurking water/petrol/grot. I've also jet-washed the outsides to de-sludge the unit -- since it was spreading slime to everything it touched -- and will be aiming to do a bit more of a tear-down, in-depth inspection, and thorough cleaning over the weekend, if work doesn't get too crazy.

It's amazing how much time it takes to get the compressor out of its hidey-hole!

  • Like 1

Share this post


Link to post
Share on other sites

Teardown time!

1280-IMG_20180928_151159.jpg

1280-IMG_20180928_151318.jpg

Not pretty, but cleaned up pretty easily and there's no scoring in the bores. The check-valves all seem to work quite nicely, and I cleaned out the passageways as best as I could. One of the bolts holding the inlet manifold down has a pretty gacked thread, so I've got a tap on order to chase the threads in the head just to make sure, and I'll get some new bolts on order. (1/4" UNF, so nothing particularly exotic.)

I also had to break up the remains of the filler cap, since it seemed to have bonded itself into the threads and was stubbornly refusing to rotate. (I'd drilled two holes through it so that I could use circlip pliers to try unwind it. It bent the circlip pliers, then the edges of the holes started to break up.) Very careful -- almost surgical -- chipping with a thin chisel, and picks...

1280-IMG_20180928_165251.jpg

A tap for chasing the threads in the filler cap is also on its way. (1" 14TPI, as best I can tell.)

Salvaged the dipstick, though! Should be able to re-use that in the new filler cap, with any luck.

1280-IMG_20180928_165308.jpg

1280-IMG_20180929_173331.jpg

The wash-out with petrol, and new oil, got rid of a good bit of water and oil that was lurking in the passageways, and the bulk of the grot on the inside of the case.

1280-IMG_20180929_173339.jpg

That's what was left in the sump. Also lurking there is the remains of the filler plug.

1280-IMG_20180929_174234.jpg

Sludge vs Industrial Jetwash: Jetwash wins.

1280-IMG_20180929_175219.jpg

Concerningly, the little relief valve on the oil pump looked like it was stuck open. It's also picked up a few fragments of the plastic filler knob after my previous precision removal process, but it was already showing signs of problems even before then. The back-side of the other part to this relief valve had a much older-looking deposit built up on it, and it was wedged open.

1280-IMG_20180929_175233.jpg

It's a pretty clever little mechanism, this oil pump. The shaft of the eccentric is the pump piston, and it's hollow -- with a little brass orifice in the end -- so that the pressurised oil squirts up it and is forced into the crankshaft; the pressure relief is a flat plate over a drilling, held down by two little screws with springs, such that once the pressure reaches its limit, it lifts the plate and squirts out. Nice piece of design and engineering.

Unfortunately, a combination of that contaminated oil and a completely-bypassing oil pump has not done the crankshaft or con-rods any good. I ran out of time today to investigate further, but there is discolouration on the crank, and the big end of the №1 rod is scored up pretty badly. I haven't removed the №2 rod yet, but I expect it to be more of the same.

1280-IMG_20180929_185042.jpg

I will investigate further tomorrow. For now, I'll remain optimistic.

  • Like 1

Share this post


Link to post
Share on other sites

Tamber,

 

You have tried as hard as you can to recover the one that you have.  I have got on that works if you would like to have it. 

 

John.

Share this post


Link to post
Share on other sites
11 hours ago, attleej said:

Tamber,

 

You have tried as hard as you can

Would suggest he's not finished trying yet.  Whole thing looks like it could live again to fight another day. With a bit of patience and skilled engineering, it'll be good.

Loved the bit in the vid, earlier on, pouring petrol straight down the carb to get it to run.  You might need a better supply if you are planning a run out somewhere, perhaps a fairy liquid bottle.  You can just squirt it in when you need to put your foot down

  • Haha 1

Share this post


Link to post
Share on other sites
11 minutes ago, Zero-Five-Two said:

Would suggest he's not finished trying yet.  Whole thing looks like it could live again to fight another day. With a bit of patience and skilled engineering, it'll be good.

Yup, barely gotten started on it yet; this is just the tear-down to find out how bad it is. I do enjoy my suffering. 😁 I certainly don't think it's so far gone as to be irreparable. Certainly not by the standards of some members of this fine forum, who could probably rebuild it if all that was left was the broken filler cap!  😁

The other rod is as bad as the first, no great surprises there.

1280-P9306717.ORF.jpg

1280-P9306718.ORF.jpg

I also cracked  open the Drawer of Excessive Precision* for my micrometers and did a quick bit of measuring.  The rod journals seem to be within the realm of cleaning up sufficiently with a bit of polishing; the big end bearings having taken the brunt of the damage as expected, being white metal.

The machinists precision G-clamps gave me some numbers (I'm majority metric, so bear with me! 😁) :

№1 rod journal: 22.22mm, №1 big end (vertical, i.e. in line with the rod): 22.5mm. Clearance of 0.28mm, or ~11thou.

№2 rod journal: 22.3mm, №2 big end: 22.45mm. Clearance of ~0.15mm, or a midges under 6thou.

Big ends are just a touch out of spec. :) I'll see what the crankshaft mics out to after I've polished the journals, I can live with it being a hair undersized so long as I can get the rods to match it. I still need to finish tearing the compressor down fully, measuring the bores and whatnot, but so far it looks otherwise to be pretty good. I'll just keep on keeping on, for now. (I also have a couple of weeks booked off work, in the hope that I can put some more time in on the Bedford; so naturally it's going to rain constantly until I run out of time, I'm sure~)

snap-1538343541.png

(* Above the Drawer of Insufficient Precision, which houses all my hammers and other tools of "Fit, damn you")

Share this post


Link to post
Share on other sites

I've done a few other little bits and bats since the last update, mostly just putting wiring back together post-'fire' and connecting both beacons up so they now work on the switch. Oh, and some little brackets and whatnot so that can mount a second gauge (Well, so that I can put the air pressure gauge back where it belongs, and still have the tachometer.) along with a hazard switch; now the hazard lights work on a switch, rather than having to twist wires together.

pa147008.jpg

I still need to tweak the bracket for the indicator switch, because it doesn't fit where I first planned it, but that's not the end of the world. All the wiring will be tidied up when it's closer to being completed.

The compressor's been broken down a bit further, and I've got a bearing separator on order so that I can pull the ball-bearings off the compressor crankshaft. The ball-bearings seemed okay at first, but I've noticed that one of the front ones was beginning to feel (and sound) a bit crunchy, so I'm going to replace all three.

Somewhere, I have a notebook with all the measurements I've made. The bores are both in great shape, not tapered or ovalled; and... I'll have to go dig the notebook up to run through the numbers for the crankshaft, but the rods certainly don't feel loose on the crank after giving the crank journals a gentle polishing.

I've also run through the various threads that needed cleaning up (Mostly 1/4UNF; the thread on the nose of the crank is 1/2" BSF, and I'll need to get a new castle nut for that, but I don't see that causing much bother; and the thread for the filler is 3/4" BSP which is handy since I have hydraulic blanks spare in that size. :D )

And I've also gotten a little bit more welding done, mostly just adding some support to the battery tray to stiffen things up.

pa147001.jpg

The air-tank carrier was also tacked in place, so that it can be welded fully at a later date. It's not much fun working in a yard that's slowly turning into a mud-pit, though.

working-conditions.jpg

It's not the worst I've had to work in, but it's still distinctly less than pleasant when you're slopping and sliding around trying to move through the work area; it's too much like site-work at my day-job! Also, I keep catching myself on the legs of those metal screens all the time! :grr: It is amazingly frustrating, working out in the back of a car-park!

Edited by Tamber
missed a bit about measurements.
  • Like 1

Share this post


Link to post
Share on other sites

As might be evidenced by the lack of updates, this project has almost completely stalled for now.  I'm still collecting parts, and trying to put things together, though. (Who woulda thunk that work moving to a bigger workshop would make it harder for me to haul the truck in from time to time?)

Current little bit of progress to be made is that I've flexible brake hoses made up. They've been made with M12x1.0 ends on them, and I have matching union nuts for the hard-line, so I can at least get that one little step closer once it's no longer a swimming-pool underneath the truck.

Share this post


Link to post
Share on other sites

And, just so I've got something useful to bump this topic over, I have gotten some more progress on the driver's door. The infill/strengthener piece at the bottom of the door, in particular.

photo_2018-11-18_18-11-48.jpg

It's being made out of two pieces, to begin with, since I didn't have a big enough single piece to do the whole lot in one go. I was catching a lot of flack for the tin-bashing, though; too noisy for some of my co-workers. 😁

Probably could've repaired the original, but it's quite lacy in parts and I fancied giving a go to bashing one up myself. After all, that's mostly why I embarked on this project, and why I'm not adverse to re-visiting some parts and finishing them up better/differently once I've had more practise. Which I will be doing with part of the outer door skin repair patch, which I really should've made up in two parts rather than try to do it all in one. Live and learn. :)

Hopefully, once I get this piece finished up and fitted, I can give the door innards a coat of paint, then refit the door to the truck rather than have it sitting around in the workshop; which will be a bit of a boost because parts will be going back on again. Goodness knows I need the boost...

  • Like 2

Share this post


Link to post
Share on other sites

Nothing like a good bit of fabrication to boost morale, especially when it comes out nice.  You can step back and say, "I made that"  Even better when you get it fitted back on the wagon.

  • Like 1

Share this post


Link to post
Share on other sites

I'm looking forward to the door going back on, and getting glass into it. No idea when that'll be, but eventually. :)

Grabbed a spare hour or so after work on Sunday to start trying to get that underside infill put in, and start getting the bottom part of the door back to the right profile. It's pretty close in one spot, but still a good amount of persuasion required to get it back to where it should be. That's my fault for leaving it stood up in the workshop, where it's taken a bit of a beating being near the welding supplies bench.

IMG_20181202_173806.thumb.jpg.cf59a7b34b55b33f2cc6fec3b6724087.jpg

Some truck-shuffling in the yard at work (bloody brand-new LF with dead batteries that's been there for 4 months has been moved!) has left some room on slightly drier and firmer ground in front of the RL, so I'm tempted to try shift it forward out of the lake so that I can get to do a bit on the brake lines. Starting to write up the list of things that need to happen before I can get sorta-functional brakes on at least one axle, even if I have to stick the old shoes back in for now, just so I have an idea of what I might need to sort out in what order. (Starting with seals, before I end up with fluid everywhere. 😁)

It remains to be seen whether or not something else gets shuffled into that space before I get there, though. 😁

New ball-bearings and a shaft-seal for the compressor should be arriving Soon™, hopefully within the next few days; then I should be good for another crack at that. (At least the crankshaft can go back in...) I think I've also managed to source some piston rings, so I can replace the oil-control ring I broke; but we'll see how that goes when they get here.

  • Like 1

Share this post


Link to post
Share on other sites

Okay! So, it's been a bit since I last updated, I know; I reckon it's about time for an update on where things are at the moment.

Leading directly on from my last post: I quit my job.  They said to take the truck with me, too, but they'd buried it three deep in the yard anyway, as they do. 🙄 They were also supposed to be completely out of that building & yard by Christmas. Then by the end of January this year. I'm sure you can imagine how well that's gone. I still need to find somewhere that's a more permanent home for the RL, as a few seemingly-promising leads have blown away in the wind. (New job doesn't have space in their yard for me to move it down on in there, and it's probably for the best anyway. Wears a bit thin constantly being at work, even when not at work. 😁)

Anyway, let's get back on with the truck update. 😁

February 2019

Went to move 'er out to a slightly drier patch of the yard, while there was still a clear path out from behind the dead van.

IMG_20190223_151906.jpg

This'll do:

IMG_20190223_154709.jpg

Late March 2019

Had a burst of energy, so went to attack the brakes again, starting with that awful job I made of the rear axle line.IMG_20190324_151545.jpgIMG_20190324_151551.jpgIMG_20190324_165807.jpg

Much better. And while I was at it, let's continue with the piping!

IMG_20190330_164158.jpg

IMG_20190331_160118.jpg

IMG_20190331_160110.jpg

Some supports and pipe clamps will come, in time.

Early April 2019

Brake shoes back on the OSR. They're still exactly the same, done nothing with them yet, so they'll have to come back off again to be re-lined as needed.

IMG_20190407_135113.jpg

After wrestling with the wheels, I went and looked for some nice easy jobs to do... ideally lying down in the shade under the truck. :D Checked & topped up the front axle, and the NSF tracta joint.

IMG_20190407_155353.jpg

The OSF, which has the most leakage -- I've got replacement seals for both sides, but considering that I might have to move the truck on short notice, I didn't want to really tear into anything that would render it immobile for any considerable amount of time -- also has a level plug that was apparently tightened by the Hulk.

IMG_20190407_162128.jpg

Ugly, eh?

Early June...

The rest of my struggling with the brakes, from the day after -- when most of the visible work got done -- didn't end up in that video, because my editor was becoming clumsy and struggling with the footage I'd already loaded into it. I'll probably make a part 2 with all of that stuff in. Maybe.

...in about a month, at the speed I edit video.

Anyway, more brake stuff happened! More specifically, I fit those two front brake cylinders, plumb them up, and get the system properly filled with brake fluid. I also sorta bled it, but managed to destroy my cheapie vacuum bleeder by having the little fluid-trap pot end up upside down, and the pump pulled fluid in, which just wrecked the O-rings. B-|
I also re-fitted the brake shoes on the nearside, as well, so that the cylinders have some resistance to push against. All those shoes will have to come back off again at some point, either to be cleaned up (where they're of adequate thickness and not contaminated) or to be re-lined. At that point, I'll properly clean & check the drums to see if any of them need resurfacing, and how close they are to end-of-life spec.

(I have just found that The XMod has 2 sets of what appears to be the right brake shoes, judging by what I can see in the pictures, amongst some other useful parts.  However, the Bedford category has RL and MK stuff mixed together, so I'm holding off on any big parts until I can confirm they're actually the appropriate parts (If anyone has a list of NSNs for RL parts, like the clutch, and brake shoes/brake shoe kit, I'd love to cross-check against it! 😁))

For now, though, there's a hint of braking if I pump the brakes a lot, which is a good sign. I just need to get more fluid, and either a helper, or another (better) vacuum bleeder (and not draw fluid up into it. B-|)...

Early July

July sorta became electricals month. Just minor things, a couple of worklamps...

IMG_20190702_190222.jpg

...an isolator switch...

IMG_20190702_183554.jpg

(I wasn't entirely sure where to put it, and maybe accessible from the outside would've been better; but it'll do just fine there, since I can see it/grab it from the driver's seat, in the event that anything goes horribly wrong.) Still need to extend the alternator wiring to be on the battery side of it, to ensure it fully kills power while running, but it's good for the time being.

Anyway, at this point, I should note that thing about my ex-work having to be out of that yard by January? Well, by this point, the housing developers are getting a bit miffed at all the stuff still piled up around the industrial estate -- including stuff like truck-mounted equipment that was dumped near the original building they were working out of -- and have started condensing the stockpile of crap into that one yard.

I got there one day, and found the RL boxed in. 😁 Not ideal...

IMG_20190702_181524.jpg

On the electrical front, I re-ran some wires that were -- quite frankly -- routed stupidly the first time. I know better now, so I've fixed it. And then I loomed it all with PVC loom tape. (Not the same as electrical tape; it won't turn into a giant gooey mess after 6 months.)

IMG_20190707_140310.jpg

And then, a jail-break happened.😁

IMG_20190707_160546_620.jpg

IMG_20190707_155247.jpg

Sadly, these shenanigans weren't caught on video, because I forgot to put my video camera on charge. B-| Such is life. Anyway, an escape was made to a different place to park.

IMG_20190707_155201.jpg

That about does it for now, I'm in stockpile/scheme mode again. I managed to make the wiper motor twitch a bit while I was playing with wiring, and went to investigate the linkage. One of the wiper spindles is seized up, and the other one turns out to have a bound up and twisted linkage. Unfortunately, I found out about the bound up linkage after I'd disconnected the link bar from the seized up spindle, and the next attempt to move the wiper motor pulled the other spindle out of the rusted roof metal. B-|

Ah well, it needed fixing anyway, right? 😁 Currently in two minds about those spindles, and need to do a little measuring before I decide what route to go. Either way, the roof has to be repaired to be able to take the loads that the wipers will impose, so that needs to be done no matter what; but whether I repair the spindles, or re-engineer something similar but from a different vehicle/manufacturer, depends on how easy it is to get appropriate-sized wiper arms and whatnot.

But the wiper motor still works, which is nice. Just have to do a minor repair where the mounting screw for the cover is snapped off in the stalk for the switch, and it should be perfectly serviceable. It's the little things, yanno? 🙂

  • Like 5

Share this post


Link to post
Share on other sites

Hi mate if you pm me with your contact details I will dig out the NSN for the parts you have asked for if you still need them .

Cheers Butch

Share this post


Link to post
Share on other sites

Hope the new job and parking facility work out alright for you, but good to see you are still making progress with the old girl, even if it is a bit slower than you would like.

If you are struggling with the wiper linkage and spindles, you could try these people;  Transervex of Bootle.  They mainly supply the bus and coach market,  but have a massive range of parts in stock and can make/repair to order.

Share this post


Link to post
Share on other sites
On 7/30/2019 at 10:01 PM, Zero-Five-Two said:

Hope the new job and parking facility work out alright for you, but good to see you are still making progress with the old girl, even if it is a bit slower than you would like.

If you are struggling with the wiper linkage and spindles, you could try these people;  Transervex of Bootle.  They mainly supply the bus and coach market,  but have a massive range of parts in stock and can make/repair to order.

Thanks! Things seem to be working out well enough at the moment. 😁 Progress is progress, and all that. In exciting news, the RL does seem to be able to fit on the back of work's big slide-bed; the only potential concern is height. (And that's mostly me being a worry-wart, I think.)

So far, I've managed to free up, re-lubricate, and straighten the linkage of one of the wiper spindles; and elsenet, someone turned up some useful parts that may come in handy. Though it's always good to know more places that might have other parts, if needed! 👍

Apparently, Series LRs have a little adapter drum that attaches to the 1/4"ø shaft with a grub-screw, and converts it to a 1/2"ø push-on spline; and nice short wiper arms that then fit onto said 1/2" spline. Bonus, they're inexpensive parts.

https://www.paddockspares.com/stc987-wiper-splined-adaptor-drum.html

and, for example, https://www.paddockspares.com/prc4276-front-wiper-arm-right-hand-drive-vehicles.html

I'll see where that leads me. If it goes nowhere, then at least I'm not out of pocket very much. 🙂

Share this post


Link to post
Share on other sites

August 2019

An escape, just in the nick of time, as the final objections to the demolition of the remaining Loco Works are withdrawn.

P8249880.jpg

Didn't make it up to the unit. Instead, she had to sit in work's yard for a bit, next to a pair of scrap DAFs, probably having the vehicular equivalent of flashbacks to the breaker's yard.

This weekend, I broke out the welder at work, stripped the bumper off, and got the broken bumper mount welded back together. How'd it get broken? Weeeell... there were some escapades on the rescue mission, extracting it from the Loco Works, resulting in the RL ramming the crane on the back of the slide-bed.
IMG_20190914_122320.jpg

Anyway, once I got that stuck back together, we loaded up, and I drove the whole mess on up to the unit. (First time I've loaded a slide-bed by myself, and it didn't fall off again, so I count that as a success! I also managed the whole drive up there without breaking anything! Bonus!)
IMG_20190914_132510.jpg

Straightened the bumper a little, but didn't want to try push it any further, because the existing cracks at the bend points were already spreading; and it's easier to fix it if it doesn't snap completely. It should straighten better with some heat on it, and then I'll weld and reinforce it.
IMG_20190914_172643.jpg

Slowly but surely, things are coming together again. I've started reassembly of the compressor; one piston & rod is back in, I have a replacement oil control ring for the other one. (It yet remains to be seen whether or not this replacement actually fits. I hope so!) Still going to be held up by not having the right screws for the oil pump pressure relief. (The ones I got are very close to fitting, but are too big. I've ordered some of a slightly smaller size, but we shall see.) I also need to get another spring to replace the one that disintegrated upon removal. I will, of course, document dimensions/thread counts/etc when I find things to be satisfactory.

In short, it's a herd of small pieces that are getting in my way at the moment. But I'm hoping it shouldn't take too long to have the compressor back up and running again. We shall see.

  • Like 3

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...