Jump to content

Normandy Jim

Members
  • Content Count

    16
  • Joined

  • Last visited

Everything posted by Normandy Jim

  1. Got one in stock, and another to be skimmed, got 3 GMC engines for rebuild in the future as well...Soon to start on the ROYAL DUKW...
  2. Hi Gordon, sorry not responded, got the old girl running, there was a problème With the manifold, when it was skimmed they she ares. 2 off the bolts, repaired it But caused an interna crack between the joints..removed and stripped down then repaired...bingo..Thanks for your assistance anyway,,take care
  3. Good morning Richard, Bad news on Engine, started and ran well for an hour, everything normal, temperature stayed 140..Then started running erratically, overheating and serious vibrations...back to square one again..fun fun fun..Thankfully we have no clients visiting at the moment so no tours(although no clients no money coming in) so time to solve the problems..After this got the 1937 SAURER, Bedford QL, and Humber...2 big projects rebuild of QUAD and MATIDOR...Thanks for your help will keep in touch, keep safe in these bizarre times..
  4. Thanks Richard, It's the first time thats happened to me, shall check it over Monday..
  5. Will try that on Monday, when i"m next at work, Had the manifold skimmed, new central locating rings and gaskets fitted...Shall give you the news next week...thanks
  6. The fuel is fresh and new, with additive and filtered, besides that would effect all cylinders not just 1+2...But thanks anyway
  7. The pushrods on 1+2 cylinders were damaged, be that being due to sticking cam followers or valves or weak return springs???? so to be safe all was changed..
  8. All ignition system is new, problem lies with 1+2 as when HT leads are disconnected the engine tone stays the same, disconnect the other 3<6cyl engine tone drops..Im running engine without rocker cover and side covers, getting oil to all..Will be back on it again on Monday...Will let you know the outcome..
  9. First post for a while, got a GMC running Like a bag of nails, new headgasket fitted, four new push-rods, valves and springs on no 1+2 cylinders, carb + fuel pump overhauled, LT and HT system changed With new coil..enging timing set up and strobed, fins well fire 10-15 mins then starts to miss on 1+2 again, got 9.5 bar compression through all 6 cylinders, good sparks, checked, rechecked, valve clearances, CBs, etc, all good...
  10. Thats not my welding, its the previous mechanics, who has butchered most of our fleet of ww2 vehicles, he removed the original oil filters and fitted modern filters and used air compressor pipes for oil to pass, also changed the fuel systems to accomodate a modern car primer pump, The problem i've got is to repurchase the complete systems as he threw everything out.. The vehicles are WC52 and command car, Kubelwagon, Willy's Jeep, Bedford QL, Humber and Morris Quad Luckily he wasnt allowed to touch our GMC's and SAURER.. Thanks for your help..
  11. Thanks for the help Mike, I met Chris on 5th June when he visited the DDay Acadamy in ROTS.. Seems he will be able to locate most of the parts I need for the vehicles This is my Solex to be fitted with no linkages/control rods The others are the Zenith fitted..
  12. Have you got Chris Morters email or phone number, As I'm in Normandy France not UK..The problem with our QL it cuts out on steep inclines due to the Zenith carb being half the size of the Solex...Thanks for the help...
  13. Have got in touch with Champ spares, NMVG, and Classic spares, for our Humber, Bygone are dealing with the QL, but may struggle for the accelerator linkages..The Quad is an ongoing project along with the Matador...Thanks for the help anyway..any other info please do forward on..
  14. my first time on the forum and hoping some off you nice people will help. I work at Dday Acadamey ROTS..I'm after the following pieces Humber rear and front brake cylinder kits, Hub seals the same; Front P/Shaft nuts and bolts Bedford QL Solex RZ FAIPO Carb Kit X2, Complete accelerator linkages on side of carb.. The bedford currently runs on a Zenith from a 1500 wt bedford The previous mechanic ripped out the system, cut, welded and threw away what was left, the bedford runs well, until a steep incline...So I
  15. Can somebody post a picture of the throttle linkage on Bedford ql?. The one I'm working on has zenith carb, changIng go original soles but no throttle pieces..much appreciated
×
×
  • Create New...